Mina produkter

Logga in för att följa kategorier och för att få genvägar i denna meny
Visma Administration, Fakturering & Förening
avbryt
Visar resultat för 
Sök istället efter 
Menade du: 
Highlighted
NY MEDLEM

Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Hej,

Vi har efter flera år med fungerande VPN-uppkoppling nu erfarat samma fel som flera andra i detta forum. Nämligen "Det gick inte att ansluta till databasen". Det är endast när vi försöker ansluta via VPN, klientuppkoppling inom nätverket är inga problem.

Har läst att ni tycker man ska skapa nya användare och slå på Behörighetskontroll. Behörighetskontrollen är alltid på och ny användare avhjälper inte problemet. SQL:en är up and running.

Vad kan vara felet? Börjar bli lite uppretad över att Visma krånglar och strular så mycket nu för tiden!
9 SVAR 9
APPLICATION SPECIALIST

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Hej Niklas Hamrin!
Det är alltid svårt att hitta felen eller vad som orsakar problemen när de ligger i nätverken.
Men känns som att det borde vara en fråga om rättigheter elleranvändargrupper eller liknande. Borde inte vara själva VPN-tekniken som är ett hinder frånatt kunna köra överhuvudtaget.
Men detta är något som jag måste titta vidare på för att bemöta dig med ett bra svar. Jag får be att få återkomma. 
NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Hej

Vi har samma problem. Någon som har något tips eller finns det någon guide?


NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Med lite Googlande hittar man att det är problematiskt med anslutning mot instanser (<SERVER>\<DB>) via VPN, men att det fungerar om man ansluter med TCP/IP mot IP-nummer och port.
Jag har provat och det fungerar efter att man tillåter anslutning på en specifik port och dessutom släpper porten genom brandväggen.

Nu är det naturligtvis helt beroende på nätverksuppkoppling, men jag skulle nog föredra att jobba via ett fjärrskrivbord istället. På så vis sker all databaskommunikation lokalt och blir mycket snabbare.

Jag tror dessutom att Visma förordar fjärrskrivbord framför diverse egna inställningar.
Jag hittade då inte att man kunde ställa anslutningen lokalt på klienten utan man måste ändra i företagets inställningar så det gäller alla användare.

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Med den erfarenhet vi har av en dip i det lokala nätverket (vilket då resulterade i att korrupta filer så anser då jag att fjärrskrivbord absolut skall användas.
NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Problemet är att fjärrskrivbord inte är en option om flera vill ansluta samtidigt.
NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Du bad om att få återkomma. Inga problem, men en månad för att göra detta känns lite väl. Har du kommit fram till någon lösning? Det funkade finfint med VPN-koppling innan ni uppdaterade 2018.

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Iofs men då gäller det bara om du kör mot en dator, lägger du allt i en server så kan alla köra fjärrskrivbord. Vilket även innebär att alla transaktioner och data hanteras inom servern. Man slipper alla risker med nedgång i nätverk, VPN och annat. 
NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

I vårt fall var det windowsbrandväggen på servern som satte stopp för trafiken, vilket resulteade i meddelandet "Det gick inte att ansluta till databasen" efter man skrivit in användarnamn och lösenord.

Ändrade enligt följande:

- Windows firewall with advanced security
- Inbound rules
- Redigera "Port 1433 TCP används av vissa program från VISMA"  samt  "Port 1434 UDP...."
- Flik "scope"
- Ändra "Remote IP address" till "Any IP address"



NY MEDLEM

Re: Administration 2000 via VPN - "Det gick inte att ansluta till databasen"

Tack för hjälpen Henrik,

Det var nästan rätt för mig. Jag var tvungen att släppa upp SQL-databasen för användning av alla IP. TCP och UDP räckte inte. 

Men, nu funkar det som det ska.

Tack än en gång.