Visma Lön SQL-Server konto SPCS_SYSTEM och SPCS_CommonDB

  • 0
  • 2
  • Fråga
  • Uppdaterades för 8 månader sedan
  • Besvarad
Vi har paketerat Visma Lön med App-V och kör det tillsammans med Ctirix i en terminalservermiljö. Vi gör sedan Visma Lön i App-V mot SQL (Ej Express), grunddatabserna SPCS_CommonDB och SPCS_SYSTEM är in lästa.

Med dessa tillkommer det två konton, SPCS_CommonDB och SPCS_SYSTEM.
Vad är det för standardlösenord till dessa konton?

Vi får nämligen flemeddelandet "SPCS_SYSTEM saknas eller är felaktig."

SQL- Server authententication
SQL Server and Windows Authentication mode
Foto på appteamet

appteamet

  • 80 poäng 75 badge 2x thumb

Publicerades för 5 år sedan

  • 0
  • 2
Foto på Anna Svensson

Anna Svensson, Community Manager

  • 89,302 poäng 50k badge 2x thumb
Hej!

Vanligtvis när man får felmeddelandet SPCS_SYSTEM saknas eller är felaktig brukar följande hjälpa:
  1. Om det är Vista/7/Server2008/8/Server2012:
    Högerklicka på genvägen till programmet och välj Kör som administratör. Behöver oftast göras två gånger för att det ska gå igång.

    Om det är XP/Server2003:
    Starta programmet två gånger i rad så kan det eventuellt fungera.

  2. Om det är en nätverksinstallation görs detta på servern, annars på den lokala datorn som har programmet installerat..
    Kör reparation via Visma Assist som du hittar under Start - Alla program - Visma Spcs

  3. Testa att starta om din tjänst

  4. Om det enbart är en lokal installation (Vilket jag antar eftersom ni kör i TS-miljö), så kan du även testa att ställa in SQL-instansen att endast köra mot lokala anslutningar. På en SQL 2005 kan du hitta den inställningen i SQL Server Surface Area Configuration. På SQL 2008 kan du hitta den i SQL Server Configuration Manager, gå till Protocols för det instansnamn ni använder och se till att bara Shared Memory är Enabled. Resten disabled. Efter dessa ändringar behöver SQL-instansen startas om.
Eftersom du använder en egen SQL-databas så har vi inte support på själva databasen.
Foto på QnR-Micael

QnR-Micael

  • 142 poäng 100 badge 2x thumb
Det här svaret skapades från ett sammanslaget ämne som hette Jag kan inte öppna mitt SPCS Lön helt plötsligt - Lön 100/300/600.

Det går inte att öppna Lön100. Jag får ett kryptiskt meddelande "det finns inte SPCS_system" eller nåt ditåt. Jag har absolut inte ändrat något (vad jag vet) och jag körde löneprogrammet senast för en månad sedan. Det börjar närma sig den 25, så jag vill väldigt gärna få detta löst ASAP (as soon as possible). TACK.
Foto på niclas

niclas

  • 60 poäng
SPCS_SYSTEM felet fick jag i samband med nya updatering till 2016.1
en backup av SPCS_SYSTEM låg i C:\ProgramData\Visma database backup\Visma Lon den kopierade jag till C:\ProgramData\Visma\Shared data\MSSQL10_50.VISMA\MSSQL\DATA där SPCS_Lön_Ftg1 brukar ligga. då startade visma lön igen.
Foto på Johan

Johan

  • 60 poäng
Jag fick felmeddelande om att SPCS_CommonDB redan existerade när jag startade Lön 300.

Detta löstes av:
1. Gjorde en säkerhetskopiering.
2. Avinstallerade programmet.
3. Raderade filen SPCS_CommonDB_log.ldf i "C:\ProgramData\Visma\Shared data\MSSQL12.VISMA\MSSQL\DATA".
4. Installerade programmet igen.