Ingen mapi-kompatibel e-postklient finns installerad - Administration/Lön

  • 10
  • 5
  • Fråga
  • Uppdaterades för 4 månader sedan
  • Besvarad
  • (Redigerad)
Arkiverad och stängd

Denna konversation är inte längre öppet för kommentarer eller svar och communityns medlemmar kan inte se det längre.

Kan inte skapa fakturor från Visma Administration 2000.
Sedan dator är uppgraderar med Office 2016 (o365) så lyckas inte längre Visma Administration skicka fakturor via programmet.
Standard App för e-post är vald till Outlook 2016
Visma Assist Administration är körd utan framgång
Visma Lön 300 fungerar utmärkt med att använda e-post funktionen.

Enligt tidigare frågor och svar så är det flera som har problem med detta och många problem verkar handla om MAPI funktionen. Nu fungerar ju den bevisligen eftersom det fungerar i Visma Lön.
Så de magiska funktioner som Visma Assist kan göra borde utökas med att lösa problem med e-post kopplingar på ett bättre sätt.
Foto på jonny arowell

jonny arowell

  • 270 poäng 250 badge 2x thumb

Publicerades för 2 år sedan

  • 10
  • 5
Foto på Davor P

Davor P, Champion

  • 26,256 poäng 20k badge 2x thumb
Prova att reparera Office 365 installationen istället.

Visma leter bara efter mailklienten och kan inte reparera detta problem eftersom det ligger utanför Vismas kontroll.

//Davor P
Foto på jonny arowell

jonny arowell

  • 270 poäng 250 badge 2x thumb

Det är inget fel på mapi konfigurationen eftersom det fungerar bra i bla Visma Lön

Det vore bra att veta VILKA förutsättningar som ska gälla för MAPI konfigurationen istället för att bara testa runt med olika testförsök.

Enligt tidigare  support förslag från er så kan det saknas registernycklar som era program läser av.

Bevisligen läser Admin och Lön inte samma konfig så vad kan göras?

Reparationen är körd på datorn
Foto på jonny arowell

jonny arowell

  • 270 poäng 250 badge 2x thumb
Efter att fått hjälp av Visma supporten så hittade vi en lösning som fungerade men som dock inte är helt logisk.
Det som måste göras är att verifierar att korrekta MAPI nycklar finns i registret enligt dokumenterad lösning inne på support forumet. Den var svår hitta och därför kontaktade jag Visma supporten.

http://www.vismaspcs.se/visma-support/visma-administration-2000/content/online-help/programfel-felme...

Min lösning denna gång var:
Ingen Mapikompatibel e-postklient

Vid utskrift till mejl kan du få det här meddelandet. Från och med version 5.4 av programmet är det här problemet löst. Meddelandet visas alltså endast för de som har äldre versioner än 5.4.

Arbetar du med 64-bitars version av Outlook fungerar det inte att skicka dokument automatiskt från programmet. Du får istället spara dokumentet som en pdf-fil och därefter bifoga det i ett mejl. Om du har 32-bitars version installerat ska det fungera. Du ser vilken version du ha under Arkiv - Hjälp i Microsoft Outlook.

Börja med att kontrollera att du har valt ditt mejlprogram som standardprogram för e-post i Windows. Det gör du under Start - Standardprogram - Ange dina standardprogram.

Det kan också vara en registernyckel som saknas. Tänk på att om du använder registereditorn fel kan det medföra allvarliga problem för din dator. Gå in under Start - Kör. Skriv regedit och tryck på Enter. Bläddra dig fram till HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\

Är det 64-bitars operativsystem är sökvägen istället HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem\

Se till att MAPI, MAPIX och MAPIXVER finns upplagda med datavärden 1, 1 och 1.0.0.1.

Om till exempel MAPI saknas högeklickar du i det högra fältet och väljer Nytt - Strängvärde. Ge det nya strängvärdet MAPI. Tryck Enter och dubbelklicka därefter på namnet 'MAPI'. Skriv '1' i Data och klicka på Ok. MAPIX ska ha Data '1' och MAPIXVER ska ha Data '1.0.0.1'.

Du kan läsa mer på Microsofts hemsida http://support.microsoft.com/kb/834008 under rubriken Workaround.

Foto på Henrik Borisch

Henrik Borisch

  • 216 poäng 100 badge 2x thumb
Fantastiskt, funkade direkt när jag följde din instruktion! 
Mvh // Henrik
Foto på saik-fk

saik-fk

  • 298 poäng 250 badge 2x thumb
Stort tack för denna hjälp!
Foto på Per

Per

  • 70 poäng
Funkade inte för oss. Vi kör Admin 1000 ver 1802.
Mvh Per Schunnesson
Foto på Herbert

Herbert

  • 144 poäng 100 badge 2x thumb
Du la in: MAPI, MAPIX och MAPIXVER
både under:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\
och:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem\
??

Foto på pform

pform

  • 2,898 poäng 2k badge 2x thumb
jag har också problemet, det jag kör är :

Windows Server 2012r2
Visma Administration 2000 ( 2018.05 )
Thunderbird (52.9.1)

när vi ska maila fakturor kommer " Ingen MAPI -klient bla bla bla"

Standard mailklienten är vald som thunderbird


söker jag i regedit så finns inte Windows Messaging Subsystem alls, jag har inte gjort något speciellt med servern, det här känns som det är ett problem som dom borde lösa, kanske fixa en inställning i programmet vilken mail klient man vill använda osv .. 
Foto på Davor P

Davor P, Champion

  • 26,256 poäng 20k badge 2x thumb
Av någon anledning vill Visma "tvinga" oss använda Microsoft Outlook för att det skall gå att skicka fakturor.

Nästa problem är att för att detta skall fungera på en SERVER måste du ha en uppgraderad licens av office-paketet då det inte går med den "vanliga" versionen utan du måste köra på en "Enterprise E3" licens för att kunna installera på server.......

Jag hoppas verkligen att jag har fel......

//Davor P
Foto på pform

pform

  • 2,898 poäng 2k badge 2x thumb
Tror jag hittade felet, felet är att som i mitt fall är att simple.MAPI används av thunderbird i stället för extended.MAPI 

Började räkna på det, och att behöva fixa office365 för alla på kontoret ca 5-7k exkl. moms för att kunna maila fakturor inte är ekonomiskt försvarbart, 

det för bli att förtsätta med att spara som pdf till skrivbordet och importera bifogad fil, det tar 1-2 min extra men det är det värt..

Men stödet för andra mail klienter känns som en bra ny funktion att införskaffa, nu när allt ska vara så papperslöst som möjligt ..

Förklaring :  simple.MAPI och extended.MAPI 
källa : http://kb.mozillazine.org/index.php?title=MAPI_Support


(Redigerad)
Foto på jimmy

jimmy

  • 396 poäng 250 badge 2x thumb
Jag har kört med windows 7,  Administration 2000 och Thunderbird som e-postklient och det fungerade ända tills nu när jag skaffade Windows 10

Någon som har en lösning?
Foto på Davor P

Davor P, Champion

  • 26,256 poäng 20k badge 2x thumb
Ett alternativ är att köra fakturorna via autoinvoice.

Detta medför en kostnad på 3 kr/faktura,  men du slipper lägga tid på att gå omvägar. Er tid är också dyrbar. Ni kostar 4-5 kr i minuten......
Foto på jimmy

jimmy

  • 396 poäng 250 badge 2x thumb
fortfarande inte en lösning på problemet i sig
Foto på Robert

Robert

  • 1,908 poäng 1k badge 2x thumb
Jag gjorde för ett tag sedan en ominstallation av Visma Administration 2000, och drabbades av detta. Problemet hängde ihop med att jag installerat 64-bitars versionen av Officepaketet istället för 32-bitars.
Som Jonny Arowell skriver här ovan kan man lösa det ganska enkelt genom att ändra lite i Windows registerfil. Läs Jonnys inlägg och googla lite så ser du nog hur du ska göra.

Foto på JL

JL

  • 210 poäng 100 badge 2x thumb
på en 64bitars Win 10 installation så behövde vi lägga in nycklarna i HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\




Foto på Patrik

Patrik

  • 152 poäng 100 badge 2x thumb
Det här svaret skapades från ett sammanslaget ämne som hette MAPI is not installed - Lön.

Jag har en ny HP 64-bitars med Windows 10 Pro och Outlook 365 (32-bitars) och Lön 600 (2019.03). När jag ska skicka lönebesked med e-post får jag felmeddelande att MAPI is not installed. Jag har sökt på forumet och gjort kompletteringar i Regedit enligt instruktioner men får samma fel ändå.
Outlook är standard e-postprogram och det fungerar att högerklicka och skicka. Vad behöver man göra ytterligare??
Foto på henrik2cit

henrik2cit

  • 104 poäng 100 badge 2x thumb
Det här svaret skapades från ett sammanslaget ämne som hette Skriva ut som e-post i Visma Administration samt Lön med Office 2019.

Vi har plan att uppgradera ett antal kunder till Office 2019 men i vår testmiljö och när vi testat hos kund går det ej att skicka som E-mail från varken Visma Administration eller Visma Lön, felmeddleande är "Inte MAPI-kompatibel e-postklient finns installerad"
Foto på Herbert

Herbert

  • 216 poäng 100 badge 2x thumb
Då är frågan om det går att lösa MAPI problemet på ett 64-bit O365/Office 2019? Ska strängvärdena då in under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\ ?
Jag la dem i HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem\ men det löste inte problemet...

(Redigerad)
Foto på Christel

Christel

  • 6,214 poäng 5k badge 2x thumb
Supporten löste faktiskt detta för mig. MAPI problem går att få ordning på.
Foto på Herbert

Herbert

  • 216 poäng 100 badge 2x thumb
Det löste sig galant!
MAPI, MAPIX och MAPIXVER skulle in på båda platserna i registret som några också har tipsat om här på forumet. Dock står det fortfarande inte så i Vismas instruktioner, där står också att det inte fungerar med 64-bitars Outlook vilket det ändå kan göra efter ovanstående ändringar i registret...
Foto på FancyCheer

FancyCheer

  • 172 poäng 100 badge 2x thumb
Det här svaret skapades från ett sammanslaget ämne som hette Ingen MAPI-kompatibel e-postkient finns installerad.

Jag ska skicka fakturor med epost men får felmeddelandet Ingen MAPI-kompatibel e-postklient finns installerad. Jag har läst på andra trådar här och varit in i regedit och lagt in det som rekommenderas under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem, men det fungerar ändå inte. Jag har även kört en reparation av Office 365, men det hjälpte inte heller. Jag har Windows 10 och Microsoft Office 365. Jag kör med Outlook som standard mailprogram. Jag har VismaFörening installerad (version 2015.10).
Foto på FancyCheer

FancyCheer

  • 172 poäng 100 badge 2x thumb
När jag la till även på HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem\ så löste det sig för mig.

Den här konversationen är inte längre öppen för kommentarer eller svar.