Rensa cachen - "lyxmetoden" - eEkonomi

  • 1
  • 4
  • Fråga
  • Uppdaterades för 5 månader sedan
  • Besvarad
  • (Redigerad)
Till dig som berörs av supportens standardsvar “Har du tömt cachen”? Här kommer en alternativ lösning till att tömma all cache och alla kakor:

Korta versionen
Adress: chrome://settings/siteData
Search cookies*: visma (endast gemener)
Under sökrutan, klicka: Remove all shown*
* eller svensk variant / översättning

Långa versionen
Har du fått förslag om att tömma cachen och/eller rensa kakor från Visma support? Trött på att samtidigt behöva förlora information om inloggning och andra sparade uppgifter rörande andra sajter än just Vismas, t ex sparat person- eller organisationsnummer till bankens och skatteverkets inloggning? Här är en alternativ lösning, lite mer kirurgisk, för att råda bot på att inte bli snuvad på fler goda kakor än nödvändigt:

Det här gäller bara Chrome, den av Visma för eEkonomi rekommenderade webbläsaren:

1. På adressraden (i Windows CTRL+L, i macOS CMD+L), markera, kopiera och klistra in följande: chrome://settings/siteData

Ovan: Förhoppningsvis får du som jag upp en lista över samtliga sparade kakor och cache-data.

2. I sökrutan uppe till höger, skriv med gemener: visma

Ovan: Det är viktigt att du skriver "visma" med gemener, bara små bokstäver (den här rutan är skiftlägeskänslig).

3 alternativ 1. Precis under sökrutan med texten "visma", klicka Remove all shown (eller motsvarande svensk variant*) för att ta bort all cache och alla kakor relaterade till just Visma - utan att drabba andra sajter.
Klart! Testa att logga in på Visma på nytt ...

Ps. Alternativ 1 ovan tar även bort inloggningsinformation som sparade användarnamn, lösenord, tillfälligt lagrad tvåfaktorautentisering etc. Visserligen gäller detta bara Vismas egna sajter nu men det är inte gott nog om du frågar mig. Jag vill helst bara åtgärda det specifika problemet, inte förlora sparade inloggningar etc. Därför finns alternativ 2 nedan:

3 alternativ 2. Med respekt för att alternativ 2 eventuellt bara löser just mina specifika problem jag hade idag, här kommer stegen jag vidtog:
Klicka på raden identity.vismaonline.com
Klicka på krysset till höger på alla rader som börjar med SignInMessage. (följt av en massa siffror och bokstäver) för att ta bort dessa.
Klart! Testa att logga in på Visma på nytt ...

Ovan: Jag har tagit bort alla rader som börjar med SignInMessage. Därefter fungerar mitt eEkonomi igen.

Om alternativ 2 inte fungerar för dig, utför gärna lite alternativ kirurgi på egen hand och uppdatera tråden här nedan med vad som löste just ditt problem. Tillsammans kan vi kanske hålla den här tråden uppdaterad med exempel på vad som löser de vanligaste problemen gällande cache - som inte begär att vi behöver tömma hela kakburken i papperskorgen varje gång. Med tiden ringar vi in detta och överlämnar till utvecklingsavdelningen ...


Trevlig helg, vecka, what ever ...


* Knapptext och skärmbilder är på engelska eftersom jag kör en engelsk variant i min Mac och Chrome inte stödjer byte av språk på Mac utan att jag ändrar språket i operativsystemet.
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb

Publicerades för 10 månader sedan

  • 1
  • 4
Foto på Pacsac

Pacsac, Champion

  • 48,846 poäng 20k badge 2x thumb

Tack för hjälpen med detta.

MEN varför ska detta behöva göras?
Foto på Khedron Wilk

Khedron Wilk, Champion

  • 15,810 poäng 10k badge 2x thumb
Lite förenklat:

En webbläsare försöker "cacha" så mycket som möjligt. Det vill säga spara en kopia av allting som laddas ner. Tanken är att nästa gång man surfar in på samma webbsida så kollar webbläsaren först i den lokala cachen om man redan har en aktuell kopia. I så fall används kopia istället för att lägga tid på att gå ut och hämta den igen på Internet. 

Så när man surfar in på en websida så är det rent krasst inte alls säkert den helt eller delvis har hämtats från webbservern, den kan lika gärna vara en (gammal) kopia.

Den som äger webbsidan kan sätta bäste-före på alla webbsidor, bilder, CSS, skript mm som en modern webbsida är bygd av. Tricket blir att sätta bäst-före lagom långt bort och på rätt delar, så att man minskar belastningen på webbservern och ger användaren en snabbare upplevelse. Kruxet är att många, bland annat Visma, använder sig av det som lite modernt kallas för "kontinuerlig utveckling". Istället för att släppa ett fåtal större uppdateringar nära få gånger om året så uppdateras till exempel eEkonomi ibland  upp till flera gånger i veckan. Och då kan det finnas gamla resurser/websidor hos användaren som gör att inte den senaste sidan används eller till och med rent ut krockar med ny/rättad funktionalitet.

Svårigheten är att få till en lagom balans mellan cache-parametrarna och den ständiga strömmen av uppdateringarna. Kortare chache-tid = i värsta fall långsamma Visma, längre cache-tid = färre uppdateringar (eller  kanske längre tid tills fel är rättat).
Foto på Khedron Wilk

Khedron Wilk, Champion

  • 15,810 poäng 10k badge 2x thumb
Mycket bra! Motsvarande i Apples Safari blir: Menyn Safari -> Inställningar -> Integritet.


Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Jag kommer att fortsätta uppdatera den här tråden när jag får problem med cache och kakor i eEkonomi.
Nyss fick jag problem igen.

Det senaste jag gjorde var att jag höll på att bokföra utifrån Inköp > Bildunderlag. Jag höll på att lista ut hur jag skulle bokföra en viss sak och sökte svaret i en annan webbläsare. När jag kom tillbaka till Chrome och eEkonomi för att fylla i som jag lärt mig så hade det gått c a en timme, och jag fick veta att jag varit inaktiv för länge. Det jag redan hade hunnit fylla i gick tyvärr förlorat när jag fick stänga fliken med eEkonomi.

När jag sedan försökte logga in i eEkonomi igen, utifrån fliken med sidan Visma Online, så startade inte eEkonomi. Chrome fastnade i en slags loop på identity.vismaonline.com. Jag väntade en stund men loopen släppte aldrig.

Jag stängde den loopande fliken, öppnade en ny och gick till chrome://settings/siteData. Tänkte försöka igen med 3 alternativ 2 då det fungerade bra sist men insåg att jag inte hade någon rad som började med "SignInMessage." under containern "identity.vismaonline.com". Istället gjorde jag en ny 3 alternativ 3 och tog bort hela containern identity.vismaonline.com.



Så snart jag tagit bort containern enl. ovan meddelade mig Chrome-fliken med Visma Online direkt att jag loggats ut ur Vismas tjänster. Men! Jag hade trots detta inte förlorat användarnamn och lösen till Visma Online utan kunde snabbt logga in igen när jag på nytt surfade till vismaonline.com.

När jag tryckte på den stora knappen Visma eEkonomi Smart igen så dröjde det två minuter men sen dök faktiskt eEkonomi upp. Lite märkligt med fördröjningen, men jag kunde åtminstone fortsätta att arbeta - utan att ha förlorat hela kakburken igen.

Nästa gång ska jag vara lite mer kirurgisk än att ta bort hela containern.

Om du prövar dig fram så dokumentera gärna med ett svar här. Lyckade som "misslyckade" försök är precis lika välkomna då vi tillsammans hjälps åt att ringa in problemet.
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Efter en chatt med supporten kunde jag inte längre starta en ny chatt i ett annat ämne. När jag klickade på "Starta chatt" i hjälpen så fick jag bara upp den gamla chatten, utan möjlighet att komma i kontakt med supporten igen - jag kunde bara läsa det som skrivits om förut. Det spelade ingen roll om jag startade om Chrome.

Min lösning:

  • Öppnade ny flik

  • Surfade till chrome://settings/siteData

  • Skrev visma i sökfältet

  • Tryckte på papperskorgen på help.visma.net.


Efter det kunde jag starta en ny chatt med supporten .. och jag hade inte tagit bort fler kakor än nödvändigt. = Yes!
(Redigerad)
Foto på Khedron Wilk

Khedron Wilk, Champion

  • 15,810 poäng 10k badge 2x thumb
”Jag gillar hur du tänker” och ”tumme upp” :-)
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Tack KW.

Visma! Det är inte möjligt att redigera gamla inlägg. But why?


Rättning av sista punkten i mitt inlägg ovan:
  • Tryckte på papperskorgen på help.visma.net
Foto på Mita Jonsson

Mita Jonsson, Moderator

  • 30,776 poäng 20k badge 2x thumb
Hej M Risberg!

Så som forumet fungerar så kan man inte ändra i ett befintligt inlägg, men jag som moderator kan lägga in din rättning av sista punkten. 
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Okej. Tack.

Min ambition, som jag skrev i det första inlägget, var att samla en massa matnyttigt i redan i den första tråden, indexerat eller rubriksätta stycken åtminstone. Den idén sprack redan när jag kom till inlägg två och jag märkte att jag inte längre hade lov att redigera mitt tidigare inlägg.
Foto på Khedron Wilk

Khedron Wilk, Champion

  • 15,810 poäng 10k badge 2x thumb
Jag tror det är rätt vanligt (?) att man inte kan redigera gamla inlägg i webforum. Åtminstone är det min upplevelse. Orsaken är att man vill undvika att någon helt plötsligt ändrar utgångspunkten för en diskussion.

Det kan snabbt bli väldigt svårt att följa tankegångarna i en diskussion när ett inlägg som det redan har svarats på ändras i efterhand. Jag tror inte det egentligen är ett stort problem i detta forum men jag har sett forum där det inte varit låst och det... ..blir inte bra kan vi säga. :-)
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Det är väldigt vanligt tyvärr. Det har sitt ursprung i okunskap och obefogad rädsla att något ska skita sig tror jag, samt att företagsledare nog ser sina forum som produktblad stansade i sten att locka till nya kunder istället för något dynamiskt, primärt till för oss som redan är kunder.

Det är som jag upplever det egentligen inget problem i vuxna forum. Jag är medlem i flertalet där det är fullt möjligt att ändra sina gamla inlägg. Det är mycket fina forum där de som känner för det kan ansvara för sitt första inlägg och göra riktiga manualer av dem var efter som ny information dyker upp i t ex en flerårig tråd.
(Redigerad)
Foto på M Risberg

M Risberg

  • 2,818 poäng 2k badge 2x thumb
Kan också vara schyst och uppdatera tråden med ros när det går bra:

Det var länge sedan nu som jag fick ett felmeddelande i eEkonomi där jag behövde tömma cachen för att komma runt. Vet inte om det beror på något hos mig eller på att Visma kanske har förfinat programkoden. Hur som helst, det är bra! Mindre frustration. =)